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Overview
WOPR TBEdit is an Word 6.0 add-in designed to edit and assign commands to your Word for Windows 
Toolbar buttons. If you are using a VGA, Super VGA, or an 8514 display (basically a 640x480 resolution 
or better), you can use TBEdit to edit the existing Toolbar buttons or to create your own custom buttons. 

Not only can draw with different kinds of brushes, you can nudge your drawings up, down, left or right, 
one bit at a time, fill, rotate, flip, and take a snapshot of anything on the screen, turning it into a Toolbar 
button. Store your icons away in files and exchange them with other Word users. 
Microsoft, Microsoft Word, Microsoft Windows, and Toolbar are all registered trademarks of Microsoft Corporation.

TBEdit and WOPR are trademarks of Pinecliffe International.

See also:
Screen Regions
Step by Step Button Editing



Working with Toolbar Palette Files
TBEdit has two different types of button files, Large and Small. The button file types relate to the two 
basic Toolbar resolutions of Word for Windows:

Large Button File (*.TBL) 
Small Button File (*.TBS) 

If the "Large Buttons" check box is selected in the Toolbars dialog (choose Toolbars from the View menu),
then TBEdit will create and load large button files or TBL files. If the Large Buttons check box is not 
marked, TBEdit will create and load small button files or TBS files.

When you click the Load button in the TBEdit dialog, you can load either a Large or Small button file 
(depending on whether Large Buttons is selected in the Word Toolbars dialog). WOPR 6.0 includes two 
Toolbar Palette Files in your Word Startup directory: WOPR_SML.TBS and WOPR_SML.TBL. These files 
are a collection of button faces. After loading a button file, you can use your right mouse button to drag 
buttons to the Toolbar displayed at the top of the TBEdit dialog.

There are four buttons related to working with Button Palette files:

New
Choose this button to create a new Toolbar Palette file.

Load 
Choose this button to load a Toolbar Palette file. 

Save 
Choose this button to save the Toolbar buttons in the to your button file. 

Save As
Choose this button to save the Toolbar buttons in the to a different filename. Similar to the Save As 
command in Word for Windows, these button saves a copy of your work to another filename. Supply 
the standard 1 to 8 filename characters for the Toolbar file, leaving the file extension (*.TMS or *.TBL) 
intact. 



Screen Regions
Toolbar Listbox  (Below Title Bar)

This is a list of the available Word Toolbars. By default Word 6.0 includes the following Toolbars: 
Border, Database, Drawing, Formatting, Forms, Microsoft, Standard and Word for Windows 2.0. If you
want to create a new Word Toolbar, choose Toolbars from the View menu of Word. 

Toolbar Button Bar 
This is the horizontal bar of buttons for the Toolbar selected from the Toolbar Listbox. When you click 
on a button, the image appears in the Edit Area Grid below and the associated Word command is 
displayed on a button beside the Toolbar Listbox. 

Toolbar Button Palette    (Lower Left Region)

The Toolbar Button Palette is a box containing buttons stored in a button palette file. If the box is 
empty, click the Load button to open a button palette file. You can edit the button images in the button
palette and drag-n-drop them to and from the Word Toolbar. See The Toolbar Palette for more 
information.

Colors (Lower Right)

The 16 different colors for the Toolbar buttons are available here. You can assign a color to your left 
and right mouse button. Just click on a color with either mouse button (left or right), and then click on 
the Edit Area Grid to apply the color. The current color for each mouse button (left and right) is 
displayed to the right of the 16 colors. 

Edit Area 

This is the actual editing grid. Using your mouse, click the left or right button to fill in squares with the 
current color for each button. The size of the area that is colored depends upon the Tool that is 
currently selected. See TBEdit Editing Tools for more information.

Edit Preview
The image below the word "Preview" displays what the button will look like (after editing) if you Accept
the button and Update Word.

Tools Region (Bottom Right)

The Tool Region is the bottom right area where the three editing tools are pictured. 

Small Brush (1x1)
Large Brush (3x3)
Fill Region

See TBEdit Editing Tools for more information.



The Toolbar Palette
The Button Palette is the scroll box containing Toolbar buttons stored in the open button file. If the box is 
empty, click the Load button to load a Toolbar file (WOPR_SML.TBS or WOPR_SML.TBL). The path to 
the open button file appears above the scroll box of buttons. Using your right mouse button, you can click 
and drag buttons from the Button Palette to the Toolbar displayed at the top of the TBEdit dialog

Changing a Word Toolbar button to a WOPR Button Palette Image
1. From the Tools menu choose WOPR TBEdit.

- or -
Click your right mouse on a Toolbar button and select WOPR TBEdit from the shortcut menu.

2. From the Toolbar list box, select a Toolbar you'd like to change.

3. Select a button from the Toolbar Button Palette.

4. Click the right mouse button and drag the button over a Toolbar button displayed along the top of the 
dialog. Note: The image on the Toolbar is replaced and the image remains in your Button Palette.

If you want to change the macro/command that is associated with the Toolbar button, click the push 
button to the right of the Toolbar list box. The button text changes to reflect what is currently assigned 
to the selected Toolbar button.

Choose a Command Type (Macros, Command, Styles...) and select a item from the Commands list 
box. Click the OK button to assign the command to the Toolbar button.

5. Choose the Close button.

Adding a Word Toolbar button to a WOPR Button File
1. From the Toolbar listbox, select a Toolbar with a button that you'd like to add to your Button Palette.

2. Press and hold the CTRL key while using the right mouse button to click and drag the button to the 
Button Palette. The button face is added after your last button in the palette (scroll downwards if 
necessary to see the newly added button).

If you have created a set of large or small Toolbar images, you can distribute your handiwork by 
saving your images to a button file (*.TBS or *.TBL). Click the Save or Save As button.

You may want to capture or design new button images for your Button Palette file. Use the following 
steps to add a create button image to your Button Palette File.

1. Click the New Button button.

2. In the Edit Area Grid, design your own image or use the Capture button to borrow an existing image. 
For more information on using Capture or the other TBEdit drawing tools, see TBEdit Editing Tools.

3. After editing the button, click the Accept button. The new image appears after your last button in the 
palette (scroll downwards if necessary to see the newly added button).



Step by Step Button Editing
Prior to doing extensive modification to your Word Toolbar buttons, decide which resolution Toolbar you 
want to use with Word (large or small buttons). From the View menu choose Toolbars and toggle the 
Large Buttons check box. If you choose one resolution and later change to another, your Toolbar buttons 
may appear fuzzy or unclear. Jump to the Troubleshooting section of this Help file for more information on
this phenomenon.

The following steps outline the process of using TBEdit to customize a Toolbars.

1. From the Tools menu choose WOPR TBEdit.
- or -

Click your right mouse on a Toolbar button and select WOPR TBEdit from the shortcut menu.

2. The available Word Toolbars appear in the list box labeled Toolbar. Select a Toolbar that you would 
like to edit. The buttons that appear on the selected Toolbar will appear just below.

3. Click on the button that you would like to edit.

4. Change the appearance of the button on the Edit Area (the grid). Choose the Clear button if you want 
to start designing a button from scratch or use the Drawing Tools to edit the existing image. 

5. After editing the button, click the Accept button to save your changes.

If you want to change the macro/command that is associated with the Toolbar button, click the push 
button to the right of the Toolbar list box. The button text changes to reflect what is currently assigned 
to the selected Toolbar button.

Choose a Command Type (Macros, Command, Styles...) and select a item from the Commands list 
box. Click the OK button to assign the command to the Toolbar button.

6. Choose the Update Word button

7. Choose the Close button to exit TBEdit or continue to edit any or all Toolbar buttons.

For more information on using Capture or the other TBEdit drawing tools, see TBEdit Editing Tools.



TBEdit Editing Tools
Using the Capture Tool
Choose this button to capture an area of your screen to a Toolbar button. There are two Capture buttons 
in the TBEdit dialog allowing you to capture an image for the Button Palette or the Toolbar displayed 
along the top of the dialog.

When Capture is selected, use your mouse cursor to capture a portion of screen. As you move your 
mouse the image within the capture square will appear in the Preview box. Once the Preview box 
displays the image you'd like, click your left mouse button. Now, choose the Accept button to replace the 
button you selected with the newly captured button image. 

Note: Press the ESC key to exit Capture mode without capturing a button image.

TBEdit Drawing Tools
Small Brush (1x1)

Choose this Tool to change your drawing tool to a small brush. This tool will fill in a single square with 
your color when you click on a square in the Edit Area Grid. Remember that you can configure the left and
right mouse buttons for separate colors.

Large Brush (3x3)

Choose this Tool to change your drawing tool to a large brush. This tool will fill in a 3x3 grid of squares 
with your color when you click on the Edit Area. Remember that you can configure the left and right 
mouse buttons for separate colors.

Fill Region

Choose this Tool to change your drawing tool to a Region Filler. This tool will fill in a region with your color
when you click on the Edit Area. Position the pointed part of this tool on the area you want to fill with the 
selected color. For example, if the background of your "Captured" button is white and you would like it to 
be gray, select the color gray from the color palette and with the Fill Region tool selected, click on a white 
square in the Edit Area. 

Revert Button

If you have made several "boo-boos" and want to start the editing process over, click the Revert button to 
change the image in the Edit Area back to its appearance before you began editing.

Undo Button

If you happen to make a mistake in editing your button on the Edit Area, choose the Undo button to undo 
your last edit action. Choosing Undo a second time will redo your undo, leaving you with your original edit 
action. 

Clear Button

Erases the button image from the Edit Area, leaving only the background gray color. Choose this button if 
you want to design a button from scratch.

Accept Button

After you are satisfied with your edits in the Edit Area Grid, choose the Accept button to update TBEdit's 
Toolbar or Button Palette. If you made a change to the Toolbar displayed along the top of the dialog, 
choose the Update Word button to update the Toolbar images in Word.



Registration Information
The TBEdit add-in is just one part of Woody's Office POWER Pack product or "WOPR" for short. WOPR 
(pronounced as whopper) includes a collection of Word for Windows macros and add-ins such as 
Enveloper, Two by Four (2X4), WOPR FileManager and TBEdit. "WOPR 6.0" is brought to you by 
Pinecliffe International and can be yours for the low, low price of $49.95 plus a $4.50 shipping and 
handling charge ($9.50 outside the USA). Registered users of WOPR 2.0 can update to WOPR 6.0 for 
$24.95.

Benefits for registering the WOPR product include the following:

A diskette with the latest versions of the WOPR 6.0 macros and add-ins without any pesky "nag 
screens".

Getting Started Newsletter

On-disk User's Manual.

Enveloper cheat sheet to keep envelopes from wrinkling.

Full source code for WordBasic routines.

Product Support via CompuServe (GO WOPR) or the telephone (314 965-5630).

Discounts on autographed books from WOPR contributors Woody Leonhard, Vince Chen, Lee 
Hudspeth, Scott Krueger and Jim Lee.

Offbeat WOPR goodies catalog offering unique WOPR baseball caps and our WOPR Power Putty hand
exerciser.

Discounts on other fine Word for Windows add-ons, including PRIME, WinBreak PRO, FileWare and 
others.

Our internationally famous guarantee: If WOPR ever fails to live up to your expectations -- doesnt 
matter what you expected, or why -- simply return it to us and tell us how much you paid. You will 
received a full refund, immediately. Period.

and most importantly, our sincere thanks for making all of this possible.

To order WOPR call 1-800-659-4696 or 1-314-965-5630. If you reside outside of the United States see
the README.DOC file for registration information. We take Mastercard or Visa, and try hard to ship within
24 hours. To register by mail, send a check (in U.S. dollars, please) to:

Pinecliffe International
Advanced Support Group
11900 Grant Place
Des Peres, Missouri USA 63131

Site licenses and discounts for multiple product purchases (i.e. 10+ units) are available for WOPR 6.0. 
Call one of the above phone numbers for more information.



Troubleshooting
Û WOPR TBEdit doesn't appear on Tools menu

TBEdit is a Word for Windows 6.0 add-in or WLL file. If WOPR TBEdit does not appear on the Tools 
menu or the Toolbars Customization shortcut menu, move the TBEDIT6.WLL file to your Word Startup 
directory (i.e. C:\WINWORD\STARTUP) or use the File Templates dialog in Word to load the WLL file.

You can assign WOPR TBEdit to any key combination, menu, or Toolbar button. To do this, create a 
macro with the following text:
Sub Main
TBEdit6
End Sub
After creating this macro, assign the macro to any menu, key combination or Toolbar button using Word's 
Customize dialog (from the Tools menu choose Customize).

Û Buttons appear fuzzy after changing resolution

If you have edited your Toolbar buttons using TBEdit and then toggle the Large Buttons check box in 
Word's View Toolbar dialog, the buttons will appear fuzzy or unclear. 

For example: If you edit your Toolbar buttons with Large Buttons selected and then turn off Large Buttons,
Word is forced to display a higher resolution bitmap at a smaller resolution. Likewise, if the edited your 
Toolbar without Large Buttons selected and then change to Large Buttons, the bitmaps are expanded to 
the new size. Word decides how to expand and shrink the bitmaps and the results are not as slick as you 
would probably like (this is due to the different resolutions used by the small and large button resolutions: 
large buttons 23x24 pixels & small buttons 15x16 pixels).

Û Cannot load different resolution Toolbar file

Word for Windows uses two different Toolbar resolutions: Small and Large. If the "Large Buttons" check 
box is selected in the Toolbars dialog (choose Toolbars from the View menu), then TBEdit will create and 
load large button files or TBL files. If you try to load a small button file (*.TBS) when "Large Buttons" is 
selected in Word, the following error will appear:

Your Toolbar has large buttons and the button file has small buttons. Please select a large button file 
(*.TBL).

In order to load, edit, and create a large Button Palette file, choose the "Large Buttons" check box in 
Word's Toolbar dialog (choose Toolbars from the View menu).

Û Dialog buttons don't appear 3-D 

Ensure that the CTL3D.DLL file include with TBEdit is located in your \Windows\System directory. If 
TBEdit's dialog buttons still don't appear three dimensional, search your hard drive (all directories using 
File Manager) for duplicate a CTL3D.DLL file.

Û TBEdit does not show Text buttons.

Yes, this is a limitation of TBEdit. Use TBEdit, to create, edit and assign items to Toolbar picture buttons.

Û Contents of clipboard discarded

TBEdit replaces the clipboard contents with a graphic of your Toolbar. TBEdit uses the clipboard to 
manipulate the Toolbar images. The first time you run TBEdit, a dialog will appear warning you of this 
functionality (limitation). You can however, disable the prompt from appearing in the future. Tip: Prior to 
using TBEdit, paste the contents of your clipboard into a new document.

Û The Insert Button or Delete Button does not appear

Solution: Click the Update Word button.

Û TBEdit Help doesn't appear when I click the Help button 



Ensure that TBEDIT6.HLP is located in your Word Startup directory (i.e. C:\WINWORD\STARTUP).

Û Files installed with WOPR TBEdit

TBEDIT6.WLL This is the Add-In or program file. Place this file in your \WinWord\Startup directory 
or use the File Templates dialog in Word to load the WLL file.

CTL3D.DLL Program file used to give 3-D affects to the TBEdit dialog.

TBEDIT6.HLP TBEdit Help file.

WOPR_BIG.TBL Large button palette file

WOPR_SML.TBL Small button palette file



Using TBEdit 2.0 button images with Word 6.0
In order to transfer Word 2.0 TBEdit button images to Word 6.0, do the following:

1. Launch the Word 2.0 TBEdit program (TBEDIT.EXE) from your Word 2.0 Program Manager group or 
your C:\WinWord program directory. 

2. Start Word 6.0 for Windows and arrange/resize the Word application window so that you can see the 
WinWord 2.0 ToolBar Editor window and Word 6.0 at the same time.

3. From the Tools menu choose WOPR TBEdit.
4. If a Button File is not currently loaded, click the Load button and open a TBEdit button file.

5. Click the Add Button button.

6. Click the Capture button and move the square cursor over an image in the WinWord 2.0 ToolBar 
Editor window. 

7. Click the left mouse button to capture the image to the Edit Area. Edit the image if necessary and 
choose the Accept button.

8. Choose the Save button to save the images in the Button Palette to disk. 

To replace a Word Toolbar button with an image from WOPR's Button Palette see The Toolbar Palette.



Adding and Deleting Buttons to a Word Toolbar
Using WOPR TBEdit, you can add and delete Toolbar picture buttons to your existing Toolbars. The 
following example adds the ViewFieldCodes command to the Standard Toolbar.

1. From the Tools menu choose WOPR TBEdit.
- or -
Click your right mouse on a Toolbar button and select WOPR TBEdit from the shortcut menu.

2. From the Toolbar list box, select Standard.

3. Click the Insert Button button.

4. Select Commands from the Command Type list box and select ViewFieldCodes from the 
Commands list box. Click the OK button to assign the command to the Toolbar button.

5. A blank button is added to the Toolbar. Add an image by doing either of the following:

Draw an image in the Edit Area and click the Accept button when complete.

Using the right mouse button to drag and existing button from the Button Palette to the blank button. 
Use the Load button to load an existing Bullon Palette file (WOPR_BIG.TBL or WOPR_SML.TBL 
depending on whether you are using large Toolbar buttons or not).

6. Click the Update Word button

Deleting a Toolbar Button
1. From the Tools menu choose WOPR TBEdit.
2. From the Toolbar list box, select a Toolbar.

3. Locate and click on the Toolbar button you want to delete.

4. Click Delete Button.

5. Click the Update Word button.

Note: After adding or deleting a Toolbar button, you need to click the Update Word button in order for the 
change to take affect. After inserting a button, you won't be able to delete a button until Word is updated 
and vice versa.




